Internet Explorer
Internet Explorer is not supported. Please upgrade to a more modern browser.

Wiki

SERVER VERSION

Our Minecraft server is compatible with Java clients running on version 1.10 up to 1.19.
We do not have Minecraft Bedrock compatibility yet.